One of the most read articles on my website is about how to repair the somewhat troublesome headlight actuators on the 1967 and 1968 Cadillac Eldorado.
After many years they tend to fail for many owners of the 1967 and 1968 Eldorados.
One company has offered a reproduction, but from the experience some people made with it, it was said that it was very poorly made and extremely expensive. I can´t tell anything about it from my own experience though.

But there is a better and much cheaper solution to the problem in the form of a modified reproduction 1969 Camaro RS actuator which is readily available. I´ve written an article a couple of years ago what could be done and I have now updated it, as one reader sent me some excellent description and pictures of how he modified the Camaro actuator to work perfectly on his 1968 Eldorado.
Thanks for the tip Mark Maromonte from Marks Truck and Auto Repair.

Click on the picture to go to the updated article.



When the 1966 Coupe deVille arrived at my garage the AC was completely inoperable. Nothing worked - the blower would not come on at all.
So I started to search for the cause of the problem.
Everything seemed to be fine on the vacuum side. When the lever on the control panel was moved all the vacuum actuated doors operated and the master vacuum switch also seemed to work.
After some searching I found out that no current was flowing through the master vacuum switch on the firewall.
So the switch was taken apart.
If you do this you have to be very careful not to damage the membrane.
The contacts inside the switch were oxidized and so no more current could flow through.
The contacts were also adjusted so that the switch could engage properly when vacuum was applied.
When everything was put back together the whole system once again worked as it should.
It works absolutely perfect now.
Unfortunately I forgot to take pictures of the switch rebuild but here is a video on youtube where a gentleman explains how this switch works…

A video that explains how this switch works

The original AC system of the 1966 Coupe deVille is now working perfectly again.
Thats the master vacuum switch which was defective.
The rebuilt master vacuum switch.


The 1967 Cadillac Automatic Climate Control system - more issues - and a final fix. Restoring the power servo valve!

When I took my 1967 Eldorado and my Deville out of winter storage and tried everything, I ran into some problems with the Automatic Climate Control once again. (see this post with vacuum diagrams and also this posting about my blower issue and this post)
The 67 Eldorado lost its complete charge of refrigerant over the winter - so it will have to go back to the shop to see where it is leaking. All components were replaced with new ones last year and so I have no idea where it could have leaked out. A tracer was put in before the last recharge so we should be able to find the leak. I guess that it will be one of the original hoses are a bad fitting.

Another thing that bothered me was that the system basically worked most of the time, but sometimes I had to wait for a long time before the system came on, or I had to switch to “FOG“ or “ICE“ position before the blower would come on in the “Auto“ position. Then sometimes the blower would cut out again if the temperature dial was moved to a colder temperature. Sometimes the temperature would move to full heat regardless off the selected temperature in the 67 Eldorado.
I had the very same problems on my 67 Deville as well - but there also the “Vent“ and “Low“ position did not work at all...

So I started trying to find the issues and finally wanted to fix them. Sounded easy - but it took me 4 full days with long nights in the garage to fix it...
BTW - Cadillactim has an excellent trouble shooting guide for the ACC on his website - its for sale for $ 45.- and I can highly recommend it if you are troubleshooting your 1967 or 1968 Air Condition System.
The best troubleshooting guide for 1967 and 1968 Cadillac´s Automatic Climate Control Systems I got from Gary Sisk - owner of a 1968 Cadillac.
This is a very easy to follow explanation which will save you a lot of time and you do not even need any special tools.
It was written by Lynn Nicholls and can be found on Stampies Cadillac page - here is the direct link to it. I used some excerpts from his document in the explanation below:

I first suspected a vacuum leak to be responsible for most of the erratic behavior of the system. A clear indication was that the system would initially have to be switched to the “ICE“ position to make the blower come on.

Lynn Nicholls writes:

“Sometimes the dash control can be switched to the fog or ice positions to bring the blower motor on and then when it is switched back to auto the blower may stay on and the system seems to work fine until the car is shut off. If the vacuum leak is only moderate there may be enough vacuum to hold the master switch closed once it gets , but not enough to pull it closed in the first place. When the dash control is switched to fog or ice, it assumes the air temperature is cold and that the engine is not yet warmed up, but that the blower is needed immediately for defrosting the windshield. So it supplies vacuum to the master switch through another circuit, bypassing the temperature controlled vacuum switch on the heater core shutoff valve on the right fender well. This source of vacuum is enough to close the master switch.When the dash control is switched back to auto this vacuum source is shut off, but there may be just enough vacuum left from other circuits to hold the switch closed. This routine will work for a while but as the leak gets worse, there won’t be enough vacuum left to hold the master switch closed anymore and the blower will shut off again as soon as the system is switched back to auto.With these symptoms and behavior the problem is most likely the power servo. This is half the brains of the system; the other half is the control panel in the dash. The power servo is controlled by a varying vacuum signal from the transducer. This vacuum supply is a completely separate circuit from that which supplies vacuum to the master switch. High vacuum moves the servo to the maximum heater position, and with low vacuum, a return spring moves it to the maximum AC position. In between these two extremes, it regulates the air temperature door to blend warm air and cool air, and simultaneously regulates the blower speed. It also spins an internal rotary vacuum valve back and forth that makes various connections between the several small vacuum lines on the top. This rotary valve controls the various vacuum motors of the system that operate the AC, heater, and defrost functions. It is this rotary valve that goes bad. l have seen these things visibly warped, and very badly so. It must be caused by engine heat, because there is also one inside the car on the control panel that is moved back and forth by the dash control lever, but that one seldom seems to cause any trouble. A warped rotary valve leaks all kinds of vacuum and the first part of the system to be affected by low vacuum is the master switch; there’s not enough vacuum there to close it and turn on the blower. To verify this is the problem, take some spare vacuum line, some scraps of 1/8 inch pressure line (like for air shocks), and a vacuum T and manually make the connections that the rotary valve should make in the maximum AC position. The connections that the rotary valve makes in various positions are shown in the factory shop manual. Disconnect the black connector with the striped vacuum lines from the power servo. Connect the yellow, red, and purple lines together with a T; also connect the tan and blue lines together and connect the orange and green lines together. If this rotary valve is the one and only culprit the AC will now work beautifully and the blower motor will come on every time, like magic. With the dash control on high the system should be recirculating air and there will be a lot of air noise coming from under the right side of the dash; when the dash control is moved to auto the air door should move to provide fresh air and the system will become much quieter. Of course with these manual connections the system is not fully automatic and the heater won’t work right at all, however this is enough to diagnose the problem.“

I did this test (see picture below) - and with the power servo bypassed everything worked as it should. This way I knew that the power servo was to blame for some of my problems.

So this rotary valve needed to be repaired...
I removed it from the power servo and disassembled everything.

The removed power servo

after opening the cover, you can see the rotary valve in the lower center.

remove one screw and a clip and the rotary valve comes out.

The rotary valve consists of two halves which make the connections - as you can see it was very dirty and rough - and slightly warped.

I started to wet sand both halves with 800 grit sandpaper.

When everything was flat and shiny again I used some 2000 grit sandpaper for a perfect finish.

Looks shiny and flat again

Make sure that none of the ports are clogged - I used compressed air to clean everything.

When you put the two halves together lubricate with WD40 to make sure that when you put them back into the power servo that they are properly held together with the underlying spring.
After I reinstalled them into my cars - almost everything worked as it should. In the 67 Eldorado I still had the problem that in the “AUTO“ position the fan would always be slow - so I knew that the control head in the dash had a problem with the “LOW - AUTO“ switch as well.
In the 67 DeVille the “VENT“ and “LOW“ position still did not work at all...
So I switched the control panels between the two cars and suddenly everything in the 67 Eldorado worked perfectly. I never had such a perfectly working system before. Its like it just left the factory!
In the DeVille I still had no “VENT“ and “LOW“ settings working... So out came the control panels again... (its a pain in the a*** to remove and install them...)
As it turned out the “LOW-AUTO“ switch on one panel was stuck in the “LOW“ position. You can easily remove it and readjust it to work again - sorry I forgot to take pictures. Make sure that all switches on the control head are adjusted properly or they wont work as they should!
So I knew that both control heads were working correctly by installing it back to the 67 Eldorado and the other panel back to the 67 DeVille.

While the 67 Eldorado was perfectly fixed now with everything working as it should - the 67 DeVille was still giving me the problem with a non working “VENT“ position...
I studied the shop manual for hours and could not find what the problem could be. I knew that the power servo was working perfectly now and I knew that the control head was in perfectly working order as well. I verified this once again by switching these parts between the cars once again and everything worked as it should in the Eldorado but not in the DeVille.. I´m really good in switching these parts between my cars now ;-)

I started to look for electric connection problems and finally found out that no electricity was coming out of one of the three power servo connectors, but I did not know why...
After I removed the power servo once again to re-check it again it struck me - one of the pins was slightly bent and the wire connector did not make proper contact. This problem was not visible with the power servo installed in the car. It took me 2 long nights to find this little flaw... I just bent it straight and everything works as it should on both of my 67 Cadillacs. Now I have to recharge the systems and I should have perfectly working AC again... I will also install new dryers and a re-calibrated R134 POA valve before the recharge.
One the one hand the 1967 ACC is very complicated but once you know how it works its pretty easy to fix. The rotary valve in the power servo is pretty easy to refurbish, the dash servo valve is riveted together unfortunately, so its not such an easy fix, but NOS valves are still available at “Classic Auto Air“

Here is a video about the Master Switch that a gentleman posted on youtube

The 67 Eldorado in front of the garage after the AC system was fixed.


The 1967 Eldorado headlight door repairs - first spring outing

As we had an unusual warm day today with the snow melting in front of the garage, and having a couple of hours of spare time at hand, I decided to drive the Eldorados out of the garage. They both started right up as soon as the fuel pump delivered fuel to the fuel bowl. Both cars idled beautifully and it was a pleasure to see them in the bright daylight again for the first time since last October when I had put them into storage.

While I had the 67 Eldorado out I also turned on the headlights and was once again annoyed by the fact that the right one opened simultaneously, but closed slightly slower than the left one when I turned the lights off. There was a difference of around 1 second in movement between the two headlight doors.
Being a perfectionist I could not stand this, so I began searching for the problem. I already had spent some time in the past trying to fix this, but I did not succeed. The system is driven by vacuum only, so I started to look through the vacuum hoses once again. I had already exchanged a couple of them last year. I found another two brittle ones going through the firewall to the headlight switch from where a slight hissing sound was coming when the lights were on. When I touched them the hissing would become even more noticeable. I then tried to press them onto the connector of the switch and the first hose began to crumble into pieces. So I replaced all the hoses on the switch and rerouted them through firewall through the rubber insulation. There are three hoses . One is the vacuum feed (the one in the middle - I think it was yellow), one is for opening the doors (green) and one for closing (red). I also replaced the red hose behind the firewall going to a T-connector from where the vacuum is fed to the headlight door actuators. I had already replaced the two hoses after the T-connector in the past. With all new hoses in place the doors now perform almost simultaneously and quite fast. So when you run into troubles with your headlight doors, check and replace all the according vacuum hoses first. Its amazing how brittle the hoses going to the headlight switch inside the car can become over the years. It looks like they used a quite different material for these three hoses, as all other vacuum hoses are in much better shape and do not show any sign of deterioration at all.
You can see a video of the headlight doors in action below. On this video they are slightly out of sync. As it looks like they are slightly different every day, depending on temperature and engine idle...

watch on youtube or below


the vacuum diagram for the headlight doors

The vacuum diagram for the headlight doors

While the Eldorados were outside the garage my wife used the opportunity to shoot a couple of pictures she had in her mind, which she is planning to hang into the kids room. Cant wait until the medium format film is back from the photo lab. Below you can see only some digital snap shots I took.
Despite the last two unusual warm and beautiful days unfortunately winter is not over yet here in Austria, as some more snow is predicted for next week and the cars are back in the garage desperately waiting for April to come...

The Eldorado is enjoying some sun rays for the first time this year
Although she is 7 months pregnant, my wife Afra is still climbing ladders to get the best angle for her shots...
The two Eldorados in front of the garage where the snow has just melted away.


The 67 Eldorado´s Automatic Climate Control System is back in working order

Today I managed to solve the issue with the partly non working Automatic Climate Control of my 1967 Eldorado. As described in the entries below, the blower would only come on in full heat modes when the car was accelerating. The AC of the Eldorado is very similar to the one from the DeVille btw.
I suspected a vacuum leak somewhere in the system. Troubleshooting began with going through all the vacuum hoses. I replaced some which were a little worn out at the connectors. I also cut off the ends of most hoses, as they were all becoming a little loose during the last 40 years. I then plugged them in again.
Not much did change though.
When I came to the hose of the hot water valve and the delay relay, I had the first success. At least the blower motor would stay on in all “Auto” modes, even when the car was idling - but would still go off in “Fog” and “Ice”. I then suspected a leak in the power servo or in the dash controller. So I installed the power servo from my 67 DeVille where everything works perfectly, to be able to rule out any problems. Nothing changed though - the blower would still come on and off depending on the throttle position.

I then soon found the culprit of the whole issue - it was the master vacuum switch - which seems to have a problem with the internal electric switch. As I had a spare one around I installed it - and voilá - everything worked as it should. It always looked good when I checked it before.
I´m very happy that everything is back in working order. The only thing which I still have to repair is the fast idle diaphragm which completely dried out and is no longer functioning. Fortunately I do have a spare 429 engine in the garage from where I can grab and use this part - so I will repair it soon.
I then need a new condenser which is already on the way across the Atlantic coming from Old Auto Air.
By the way - Cadillactim has an excellent trouble shooting guide for the ACC on his website.

The evaporator had to be replaced as well along with the heater core. This is a pretty big task as you can see on the pictures below. You even have to remove the hood to get access to the whole unit. The fiberglass AC enclosure had to be repaired at my car as well as the previous owner tried to repair the evaporator and missed a screw and made a tear into the enclosure. The restoration shop repaired this professionally and it looks like new now.

The best troubleshooting guide for 1967 and 1968 Cadillac´s Automatic Climate Control Systems I got today from Gary Sisk - owner of a 1968 Cadillac.
This is a very easy to follow explanation which will save you a lot of time and you do not even need any special tools.
It was written by Lynn Nicholls and can be found on Stampies Cadillac page - here is the direct link to it.

Below you can find some pictures of my system:

The whole AC unit has to be removed to get access to the evaporator and heater core... The slight surface rust that showed up where the gaskets were, was removed as well of course...
The big hole on the left is where the blower motor is installed.

This is where the AC box usually is installed

You can see how much has be removed just to get to the evaporator and heater core...

I discovered the first issue at the hot water valve
The hoses around the time relay delay were leaking a little bit
For testing purposes I hung a spare master vacuum switch into the car - this solved the problem
The old fast idle diaphragm was leaking and brittle and was replaced with a better one...
1967 Cadillac Automatic Climate Control Vacuum diagram
The 1967 Cadillac Automatic Climate Control Vacuum Schematic from the shop manual -
1968 is almost identical BTW... Click on the image for a larger view!

Here is a video about the Master Switch that a gentleman posted on youtube


The 67 Eldorado´s vacuum hoses - Blower issue

The 1967 Eldorado is now back home from the restoration shop. They wanted to recharge the AC on the day before I wanted to pick it up only to find out that the condenser is also leaking badly. I´ve ordered a new on from Cold Air Products in USA in the meantime which I will install later. The recharge will then take place in spring.

During the rebuild of the whole AC system I found out that I´m also having a little issue with the blower which does not always come on at full heat. So as a first step I started to go through the numerous vacuum hoses in the car yesterday. I soon found some old and brittle ones which fell apart when I just touched them. The two hoses that fell apart were the ones going to the right headlight doors.
Original color coded hoses seem no longer available anywhere. Thats why I had to buy regular black ones and paint the red and green stripes on them. Looks almost perfect - I did not think that it would turn out this nice.
Will go through the rest of the hoses soon. With the replaced hoses the headlight doors now work 100% simultaneously, whereas before one was slower.
I still have to find the issue with the blower motor - but I now suspect either the AC controller or the power servo. It works perfectly in full cold - only when I set a higher temperature the blower will cut out. Another problem to solve over the winter... I had almost the same problem with the 67 DeVille before which I could successfully repair.
BTW - if you know of any source for the GM OEM style color coded vacuum hoses please let me know.
You can find a vacuum diagram for the headlight doors here!

There are lots and lots of vacuum hoses in the Eldorado to check - here are only a few going to the storage tanks...
I will also give them a good cleaning during the winter.

The new hose with the painted red stripe is already in place - looks some kind of original...